The document “LaunchScreen.storyboard” requires Xcode 8.0 or later. エラー

少々過去のファイルを開くにあたり過去バージョンであるXcode7.3.1を再びダウンロードし(記事を書いた時点では最新はXcode8.3.2)、シミュレーターを起動した際に以下エラーが発生しました。

The document “LaunchScreen.storyboard” requires Xcode 8.0 or later. 

どういったエラーかは詳しく調べたわけではないので分かりませんが(”LaunchScreen.storyboard”を使うためには、Xcode 8.0以降が必要ですって感じかなぁ)とりあえず解決したので解決策だけ載せておきます。

Xcodeの左側のエリア(ナビゲーター・エリア)にあるLaunchScreen.storyboard右クリックしてOpne As ▶ Source Codeと開きます。ソースが出てきますのでその中に

capability name=”documents saved in the Xcode 8 format” minToolsVersion=”8.0″ 

という部分があるので8を7に変更してください。

capability name=”documents saved in the Xcode 7 format” minToolsVersion=”7.0” 

同じように解決できるかは分かりませんがどなたかの参考になれば幸いです。

スポンサーリンク
レクタングル(大)広告